Child pages
  • Crowd Dokumentation - IBM Websphere Integration
Skip to end of metadata
Go to start of metadata


Wenn Ihre Client-Anwendung in Websphere läuft, gibt es da ein bekanntes Problem mit Webspheres XML-Libraries.

Crowd verwendet XFire, um die Anfragen zwischen der Client-Anwendung (Jira, Confluence, Bamboo, etc.) und Crowd zu managen. XFire erfordert eine neuere Version der XML-Library als die, die mit Websphere 5.1 ausgeliefert wird.

Weitere Informationen sowie ein Link zu einer neueren Version der JAR-Datei sind auf der XFire Website verfügbar.

Sie müssen die qname.jar Datei zum WebSphere\AppServer\lib Verzeichnis hinzufügen und die alte Datei entfernen.

Einige Benutzer haben über Fehlermeldungen, wie die folgende, berichtet:

java.lang.VerifyError: 
(class: org/codehaus/xfire/aegis/type/basic/ObjectType, method: writeSchema signature: 
(Lorg/jdom/Element;)V) Incompatible argument to method


Der empfohlene Fix für dieses Problem ist es die JDOM-Version, die mit Websphere kommt, auf eine höhere Version als 1.0 zu aktualisieren (Websphere kommt mit JDOM Beta 6).

Wenn Sie eine neuere JDOM-Version zum WebSphere\AppServer\lib Verzeichnis hinzufügen und die alte Version entfernen, dann sollte das obige Problem beseitigt sein.




Crowd Dokumentation Übersicht:



Crowd Doku

  • No labels